题目描述
Given any integer 0 <= n <= 10000 not divisible by 2 or 5, some multiple of n is a number which in decimal notation is a sequence of 1's. How many digits are in the smallest such a multiple of n?
输入
A file of integers at one integer per line.
输出
Each output line gives the smallest integer x > 0 such that p = 1 x 10i, where a is the corresponding input integer, p = a x b, and b is an integer greater than zero.
样例输入
3
7
9901
样例输出
3
6
12
参考代码
#include <stdio.h>
int main()
{
int n,ones,m;
while(1==scanf("%d",&n))
{
ones=1;
m=1;
m%=n;
while(m)
{
ones++;
m=(m*10+1)%n;
}
printf("%dn",ones);
}
return 0;
}
解析
暂无