题目描述
For each list of words, output a line with each word reversed without changing the order of the words.
输入
The first line contains a positive integer indicating the number of cases to follow. Each case is given on a line containing a list of words separated by one space, and each word contains only uppercase and lowercase letters.
输出
For each test case, print the output on one line.
样例输入
3
I am happy today
To be or not to be
I want to win the practice contest
样例输出
I ma yppah yadot
oT eb ro ton ot eb
I tnaw ot niw eht ecitcarp tsetnoc
参考代码
#include<stdio.h>
int main()
{
int n,i,j,k,m,x;
char a[100];
scanf("%d",&n);
getchar();
for (i=1;i<=n;i++)
{
m=0;
gets(a);
for (j=0;;j++)
{
m++;
if(a[j]==' '||a[j]=='