题目描述
Xiao Ming is only seven years old, Now I give him some numbers, and ask him what is the second largest sum if he can choose a part of them. For example, if I give him 1 、 2 、 3 , then he should tell me 5 as 6 is the largest and 5 is the second. I think it is too hard for him, isn ’ t it?
输入
Standard input will contain multiple test cases. The first line of the input is a single integer T (1 <= T <=10) which is the number of test cases. And it will be followed by T consecutive test cases.
Each test case starts with a line containing an integer N (1<N<10) , the number I give Xiao Ming . The second line contains N Integer numbers ai (-10<ai<10),
输出
For each test case, output the answer.
样例输入
2
3
1 2 3
4
0 1 2 3
样例输出
5
5
参考代码
#include<stdio.h>
int jisuan(int a[],int n)
{
int s,ma,i,j,k,b;
s=ma=a[0];
for (i=0;i<n;i++)
for (j=i;j<n;j++)
{
b=0;
for (k=i;k<=j;k++)b+=a[k];
if(b>ma)ma=b;
}
for (i=0;i<n;i++)
for (j=i;j<n;j++)
{
b=0;
for (k=i;k<=j;k++)b+=a[k];
if(b>s&&b<ma)s=b;
}
return s;
}
int main()
{
int N,n,a[15],i,t,j;
scanf("%d",&N);
while(N--)
{
scanf("%d",&n);
for (i=0;i<n;i++)scanf("%d",&a[i]);
for (i=0;i<n-1;i++)
for (j=0;j<n-i-1;j++)
if(a[j]>a[j+1])
{
t=a[j];
a[j]=a[j+1];
a[j+1]=t;
}
printf("%dn",jisuan(a,n));
}
return 0;
}
解析
暂无